Navicat连接MySQL时弹出:1045:Access denied for user ‘root’@’localhost’
错误原因: 当登录MySQL数据库出现 Error 1045 错误时,表明你输入的用户名或密码错误被拒绝访问了,也可能是你的账号不允许从远程登录,只能在localhost本地登录数据库。
解决办法如下:
- 用管理员权限打开cmd,并且cd进入mysql安装目录的bin文件。



2. 启动mysql,并且进入mysql
第一步:启动mysql服务,可以通过“net start mysql”命令实现;
第二步:在命令行输入:mysql -u 用户名 -p密码;回车;-h表示服务器名,localhost表示本地,-hlocalhost 可不输入;-u为数据库用户名,root是mysql默认用户名;-p为密码,如果设置了密码,可直接在-p后链接输入,如:-p123456,用户没有设置密码,显示Enter password时,直接回车即可。)
mysql -u root -p

3.
GRANT ALL PRIVILEGES ON . TO “root”@”%” IDENTIFIED BY ‘数据库密码’ WITH GRANT OPTION; # 修改授权,赋予任何主机访问数据库的权限
GRANT ALL PRIVILEGES ON . TO “root”@”%” IDENTIFIED BY ‘123456’ WITH GRANT OPTION
mysql> FLUSH PRIVILEGES; # 刷新权限,授权修改生效
mysql> exit; # 退出MySQL服务器
当再用Navicat连接时,密码输入上面修改的密码

AtomGit 是由开放原子开源基金会联合 CSDN 等生态伙伴共同推出的新一代开源与人工智能协作平台。平台坚持“开放、中立、公益”的理念,把代码托管、模型共享、数据集托管、智能体开发体验和算力服务整合在一起,为开发者提供从开发、训练到部署的一站式体验。
更多推荐



所有评论(0)